Page 1 of 1

PDF converts with bitmap characters

Posted: Thu Feb 05, 2009 1:48 pm
by galaxybeing
I am having trouble converting PDF documents. The resulting swfs do not allow you to select the text in them, are larger than they should be and some have severe performance problems. Upon further inspection with a swf decompilier, I see that each character had been converted to a tiny bitmap... thousands of them. I have Acrobat 8 and Reader 8 installed.

I've tried some things that sometimes work to fix the problems. Once, I was able open the pdf and run Advanced -> PDF Optimizer... and remove the embeded fonts, and the resulting document then converted correctly. Another pdf had the problem and I tried that and it didn't work, but printing it to PDF from Acrobat did create a pdf that converted correctly. I have a new pdf that has the problem and I've tried both tricks and it still won't convert correctly.

These pdfs were created from a variety of apps including, QuarkXPress, and inDesign. Any ideas why fonts in these pdfs won't survive the print2flash conversion?